L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

La valeur cible

Imprimer E-mail
11 mars 2014

Cette commande permet de trouver une valeur que doit contenir une cellule pour que le résultat d'une formule (dont dépend la cellule) ai une valeur précise. Dans l'exemple suivant, nous pourrions rechercher la valeur que doit contenir la cellule Résultat 4 pour que la moyenne soit égale à 15.

TEST
Résultat 1 Résultat 2 Résultat 3 Résultat 4 Moyenne
10 15 8 =MOYENNE(B4:E4)

Pour cela :

  • Sélectionnez la cellule qui doit atteindre une valeur précise, ici la cellule de la moyenne .

  • Outils/Valeur cible

  • Dans la zone Cellule à définir, l'adresse de votre cellule est déjà indiquée.

  • Dans la zone Valeur à atteindre, tapez la valeur que vous désirez, dans notre exemple : 15.

  • Dans la zone Cellule à modifier, cliquez sur le bouton , pour réduire la fenêtre.

  • Sélectionnez la cellule dont vous recherchez la valeur . Dans notre exemple la cellule Résultat 4. Cliquez sur le bouton ou appuyez sur Entrée.

  • Ok.

Vous constatez alors qu'Excel vous propose la valeur 27 pour atteindre 15 en tant que moyenne, vous pouvez alors l'accepter : cliquez sur Ok, ou le refuser : cliquer sur Annuler.

Le solveur

Imprimer E-mail
12 mars 2014

Le Solveur permet le même type de travail, mais avec plusieurs cellules variables et certaines contraintes.

Si vous n'avez pas la commande Solveur dans le menu Outils, vous devez au préalable installer la macro complémentaire :

  • Outils/Macro complémentaires?
  • Cochez Solveur puis Ok.
TEST
Résultat 1 Résultat 2 Résultat 3 Résultat 4 Moyenne
10 15 8 =MOYENNE(B4:E4)

Pour mieux comprendre, prenons l'exemple ci-dessus, et faisons varier chaque cellule "résultat" et imposons que chacune de ces cellules doit être inférieure à 20 et être une valeur entière.

  • Sélectionnez la cellule qui doit atteindre une valeur précise, ici la cellule de la moyenne .
  • Outils/ Solveur
  • Vous précisez ensuite la valeur que la cellule cible doit atteindre. Max pour qu'elle soit la plus élevée possible, Min pour qu'elle soit la plus petite possible et Valeur pour qu'elle corresponde à la valeur indiquée (ici 15).
  • Cliquez sur le bouton Proposer, dans la zone Cellules variables, la plage de cellules dont dépend la formule est indiquée. Si cela ne vous convient pas indiquez vous-même la ou les plages de cellules.
  • Pour ajouter des contraintes (ici <10 et entier), cliquez sur le bouton Ajouter.
  • Dans la nouvelle fenêtre, indiquez la première cellule ayant une contrainte puis indiquer la contrainte. Ici Résultat 1 doit être 7 20.

  • Cliquez sur Ajouter et recommencer pour chaque cellule avec une contrainte.
  • Pour indiquer que la cellule doit être un entier :
    • Dans cette même fenêtre, indiquez la cellule, puis dans la liste déroulante, sélectionnez ent

  • Lorsque vous avez fini d'indiquer toutes les contraintes, cliquez sur Ok.
  • Vous pouvez ensuite modifier une contrainte (cliquez sur le bouton Modifier après l'avoir sélectionnée) ou en supprimer une (cliquez sur le bouton Supprimer après l'avoir sélectionnée)

  • Cliquez sur le bouton Résoudre.
  • Excel vous propose ensuite de Garder la solution du solveur ou Rétablir les valeurs d'origine. Vous pouvez également enregistrer le résultat dans un scénario (Enregistrer le scénario?).

Gérer votre compte

Imprimer E-mail
29 juillet 2012

Dans l'onglet File (Fichier) des applications d'Office 2013, vous avez certainement remarqué le menu Account (Compte). Celui-ci sert à gérer vos différents comptes et services.

Vous pouvez utiliser soit des comptes personnels (Windows Live), soit des comptes professionnels (Office 365 ou Sharepoint).

Il existe 2 méthodes pour travailler avec plusieurs comptes :

  1. Vous ajoutez en tant que service vos différents comptes personnels et professionnel au compte en cours
  2. Vous commutez d'un compte à l'autre.