L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

Qu'est-ce

12 mars 2014
Imprimer E-mail

C'est une formule qui s'effectue sur un ou plusieurs tableaux, elle renvoie soit un nouveau tableau, soit un seul résultat. Un tableau (ou matrice) peut-être une suite de données ou une plage de cellules.

matrice de données : vous devez mettre entre crochet cette matrice et séparé chaque données par un point, les données de type texte doivent être mis entre guillemets. Exemple :

  • {1,5.2,3.3.4.5} qui comprend les valeurs 1,5 et 2,3 et 3 et 4 et 5
  • {"Cathy"."Philippe"}

En fait dans Excel, nous utiliserons essentiellement des formules sur des plages de cellules.

Pour comprendre le principe d'une tel formule, nous prendrons un exemple tout simple : 1 plage de cellules est égal au produit de 2 autres :

   

Habituellement, vous effectuez en D2 : =B2*C2, puis vous recopier la formule sur la plage D3:D10. La formule matricielle va calculer instantanément toutes les valeurs de la plage D2:D10. Pour l'établir :

  • Sélectionnez la plage D2:D10
  • tapez = sur votre clavier
  • sélectionnez la plage B2:B10
  • tapez *
  • sélectionnez la plage C2:C10
  • Appuyez sur Ctrl+Maj+Entrée (c'est cette combinaison de touche qui indique que la formule est matricielle)
  • Vous constatez alors que la formule s'écrit {=B2:B10*C2:C10}.

Qu'a donc fait cette formule matricielle : elle a appliqué la formule sur chaque ligne et renvoyé le résultat sous forme d'un tableau, c'est pour cela que vous deviez au préalable sélectionnez la plage D2:D10 :

 =B2*C2
 =B3*C3
 =B4*C4
 =B5*C5
 =B6*C6
 =B7*C7
 =B8*C8
 =B9*C9
 =B10*C10

Une formule matricielle peut également ne renvoyer qu'une seule valeur. Reprenons notre exemple : nous pouvons établir directement l'équivalent de la somme de la plage D2:D10 :

En C11, tapez la formule =SOMME(B2:B10*C2:C10), puis Ctrl+Maj+Entrée

Cette formule effectue d'abord le travail sur les matrices comme indiquées ci-dessus. Elle renvoie donc un tableau de valeurs contenant le produit de chaque ligne.
Ensuite la fonction SOMME effectue la somme de ces données.

Vous pouvez utiliser ainsi toutes fonctions qui requière 1 ou plusieurs matrices dans ses paramètres ou une suite de données.