L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

Quelques formules

12 mars 2014
Imprimer E-mail

Compter les cellules contenant du texte

 

La formule est : {=SOMME(SI(ESTTEXTE(A1:C11);1;0))}
Celle-ci établit d'abord un SI sur chaque cellule de la plage, si la cellule contient du texte, ce SI renvoit 1 sinon 0. La somme de ces 1 donne donc le nombre de cellules contenant du texte.

Moyenne

La moyenne standard : =MOYENNE(B2:B10) tient compte des valeurs égales à 0. Si vous ne voulez pas en tenir compte, il suffit d'établir la formule matricielle suivante :
{=MOYENNE(SI(B2:B10<>0;B2:B10))}
Le SI renvoit uniquement les données si la cellule de la plage B2:B10 est différente de 0. La moyenne ne se fait donc que sur les valeurs non nulles.

Compter sur plusieurs conditions

Vous connaissez déjà la fonction NB.SI, celle-ci ne permet qu'une seule condition. Ici nous allons calculer le nombre de cellules dont l'article est A et la quantité est 2 :
{=SOMME(SI(A2:A10="A";1;0)*SI(B2:B10=2;1;0))}
la formule SI(A2:A10="A";1;0) renvoie 1 lorsque la cellule de A2:A10 est égale à "A".
la formule SI(B2:B10=2;1;0) renvoie 1 lorsque la cellule de B2:B10 est égale à 2.

Nous pourrions simplifier cette formule ainsi :
{=SOMME((A2:A10="A")*(B2:B10=2))}
(A2:A10="A") renvoie VRAI si le contenu de la cellule de A2:A10 si celle-ci est égale à "A", FAUX dans le cas contraire.
(B2:B10=2) renvoie VRAI si le contenu de la cellule de B2:B10 si celle-ci est égale à 2, FAUX dans le cas contraire
Le tableau ci-dessous vous explique comment se comporte le produit entre des valeurs VRAI et FAUX dans Excel.

VRAI * VRAI = 1
VRAI * FAUX = 0
FAUX * VRAI = 0
FAUX * FAUX = 0

Sommer sur plusieurs conditions

Dans notre 1er exemple nous établirons la somme des PU pour les articles A dont la quantité est 2 :
{=SOMME((A2:A10="A")*(B2:B10=2)*C2:C10) }
Cette formule reprend celle expliquée ci-dessus, mais nous multiplions le résultat par la valeur de la cellule située dans la colonne C. Analysons chaque partie de la formule :

A2:A10="A" B2:B10=2 C2:C10
(A2:A10="A")*(B2:B10=2)*C2:C10)
VRAI VRAI 10,00 ? 10,00 ?
FAUX VRAI 25,00 ? 0,00 ?
FAUX FAUX 15,00 ? 0,00 ?
VRAI VRAI 22,00 ? 22,00 ?
FAUX FAUX 25,00 ? 0,00 ?
FAUX VRAI 27,00 ? 0,00 ?
VRAI FAUX 30,00 ? 0,00 ?
FAUX FAUX 15,00 ? 0,00 ?
VRAI FAUX 12,00 ? 0,00 ?
SOMME 32,00 ?

Dans notre 1er exemple nous établirons le total des articles A dont la quantité est 2 :
{=SOMME((A2:A10="A")*(B2:B10=2)*C2:C10*B2:B10) }
Le tableau suivant vous indique comment se comporte la formule

A2:A10="A" B2:B10=2 C2:C10
B2:B10
(A2:A10="A")*(B2:B10=2)*C2:C10*B2:B10)
VRAI VRAI 10,00 ? 2 20,00 ?
FAUX VRAI 25,00 ? 2 0,00 ?
FAUX FAUX 15,00 ? 1 0,00 ?
VRAI VRAI 22,00 ? 2 44,00 ?
FAUX FAUX 25,00 ? 3 0,00 ?
FAUX VRAI 27,00 ? 2 0,00 ?
VRAI FAUX 30,00 ? 3 0,00 ?
FAUX FAUX 15,00 ? 0 0,00 ?
VRAI FAUX 12,00 ? 1 0,00 ?
SOMME 64,00 ?