L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

SOMME.SI

12 mars 2014
Imprimer E-mail

Cette fonction permet d'effectuer la somme d'une plage selon un critère. Ce critère peut s'appliquer sur la plage que vous voulez sommer ou sur une autre plage avec la seule condition que les 2 plages soient de même taille. Sa syntaxe est SOMME.SI(plage;critère;somme_plage)

  • plage représente la plage sur laquelle le critère sera appliquée, elle peut-être la même que somme_plage
  • critère doit être sous la forme d'un nombre, d'un texte ou d'une expression de comparaison. Ce critère doit être au format texte (donc entre guillemet). L'opérateur & vous permettra de transformer au format texte toute expression dépendant d'une cellule. Vous pouvez avoir :
    • "10" --> = 10
    • A1 --> = le contenu de A1 (ne pas mettre =A1, mais si vous le désirez vous pouvez mettre "="&A1)
    • "un texte" --> = un texte
    • ">10"--> Supérieur à 10
    • ">=10"--> Supérieur ou égal à 10
    • "<>10"-->  Différent de 10 
    • "<10"--> Inférieur à 10
    • "<=10"--> Inférieur ou égal à 10
    • ">"&A1 (et non >A1) --> Supérieur au contenu de A1
    • ">="&A1 (et non >=A1) --> Supérieur ou égal au contenu de A1
    • "<>"&A1 (et non <>A1) -->  Différent du contenu de A1 
    • "<"&A1 (et non <A1) --> Inférieur au contenu de A1
    • "<="&A1 (et non <=A1) --> Inférieur ou égal au contenu de A1
    • "<>un texte"--> Différent de 'un texte'
    • "au*" ou "*au" ou "*au*" --> tout les mots commençant par 'au', tout les mots finissant par 'au', tous les mots contenant au.
      Une étoile permet de remplacer n'importe quel caractère et ne précise pas le nombre de caractères remplacés. au* trouvera aux et autres
      Vous pouvez également utiliser un ?, celui-ci remplacera 1 seul caractère, au? trouvera aux mais pas autres.
      Si dans cette formule vous remplacez au par &A1 ( "*"&A1&"*" par exemple), la recherche se fait sur le contenu de A1.
  • somme_plage est la plage sur laquelle la somme sera effectuée.

La fonction va parcourir la plage plage et pour chaque cellule X , elle va vérifier si la cellule Y, de même position dans la plage somme_plage, répond par vrai à la condition indiqué dans critère , si oui elle ajoute la valeur de la cellule X au résultat.

Exemple 1 : vous désirez sommer uniquement les valeurs supérieures à 100 dans une plage A1:A10. La formule sera donc :
=SOMME.SI(A1:A10;">100";A1:A10)

Exemple 2 : vous avez une plage B1:B10 qui indique le nombre d'enfants, une autre plage C1:C10 qui indique la prime. Vous désirez connaître la somme des primes pour 3 enfants, la formule est :
=SOMME.SI(B1:B10;"3";C1:C10)