L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

Opérateurs

6 août 2012
Imprimer E-mail

Les différents opérateurs ont leur ordre de priorité. Excel effectue les opérations dans l'ordre indiqué dans le tableau ci-dessous. Si une formule contient des opérateurs de même priorité, il traite les opérations de gauche à droite. En conséquence, si vous ne voulez pas vous tracasser, utilisez les parenthèses qui permettent d?isoler les calculs, ex. : =(4+3)*(8-5).

Excel calcule avec précision jusqu'à la 15ème décimale. Dans le cas d?un format à 2 décimales, le résultat est affiché arrondi mais Excel calcule en réalité avec les 15 décimales. En cas de calculs successifs, vous trouverez une différence. Pour l'éviter, demandez expressément à ce que le calcul soit arrondi avec la fonction adéquate, ex. : =ARRONDI(A1*B2 ;2).

Opérateur

Exemple

Signification

Opérateurs de zone

:

B3:B7

Plage simple

Espace

B3:C7 C4:F12

Intersection de plages. Ici le résultat est C4:C7 (elles sont communes aux 2 plages)

;

B3:B7;C4:F12

Union de plages

Opérateurs arithmétiques

-

-5

Négation

%

10%

Pourcentage

^

5^2

Puissance

*

5*2

Multiplication

/

5/2

Division

+

5+2

Addition

-

5-2

Soustraction

Opérateur textuel

&

B3&B7

Concaténation de chaînes. Si dans B3 vous avez « Bon » et dans B7 « jour », le résultat sera « Bonjour »

Opérateur de comparaison

=

B3=B7

Egal

<>

B3<>B7

Différent

<

B3<B7

Inférieur

<=

B3<=B7

Inférieur ou égal

>

B3>B7

Supérieur

>=

B3>=B7

Supérieur ou égal