Comprendre la fonction SI

12 mars 2014
Imprimer

le SI renvoi du texte

La fonction SI permet d'afficher une donnée différente selon le résultat. Dans l'exemple qui suit, cette fonction va nous permettre d'afficher le mot remise lorsque le montant est supérieur à 10 000 €.

Fonction SI d'Excel

La syntaxe de la fonction SI est

SI(test_logique;valeur_si_vrai;valeur_si_faux)

Dans notre cas, le test logique est : "le montant est il supérieur à 10 000 ?", ce qui, traduit en Excel, correspond pour la cellule D4 à  : B4>10000, 10000 étant inscrit en C1, cela donne donc B4>C1.
Mais le test doit toujours être une comparaison entre le montant et la valeur en C1, donc il nous faut mettre C1 en valeur absolue : B4>$C$1 (cf. les références absolues).

Dans le 2e argument, il nous faut indiquer le texte remise. Pour qu'Excel comprenne que c'est un texte, il suffit de l'inscrire entre parenthèse : "remise"

Dans le cas où la condition est fausse, la fonction ne doit rien afficher, pour arriver à cela, il suffit de renvoyer un texte vide. Qui dit texte dans Excel, dit guillemets, donc pour un texte vide, il suffit de taper "". Certaines personnes préféreront afficher "-" afin de mieux visualiser l'absence de contenu.

Nous avons donc la formule suivante : =SI(B4>$C$1;"remise";"") en D4. Il vous suffit maintenant de tirer la formule vers le bas.

Tester par vous même dans le classeur ci-dessous, tapez votre formule dans la plage rose, ne faites pas un simple copier-colle, adaptez-la à cette colonne

& lt;/html>

Avec un calcul

Dans cet exemple, la fonction renvoi le montant de la remise, le taux de cettte dernière étant indiquée en C1

Tester par vous même dans le classeur ci-dessous, tapez votre formule dans la plage rose, ne faites pas un simple copier-colle, adaptez-la à cette colonne.