L'informatique à votre portée
L'informatique prêt-à-porter

Faites appel à moi pour vos formations
sur les dpts 81, 31, 82, 11 et 67 (Strasbourg)
Confiez moi vos développements Office

FacebookTwitterGoogle BookmarksLinkedin

Un formulaire avec photo

Imprimer E-mail
5 mars 2014

Soit une liste de données dans Excel, celle-ci comprenant un champ (colonne) contenant l'adresse d'une photo sur votre disque PC (exemple : liste des produits avec code (A1), intitulé (B1), photo (C1), Nb en stock (D1) sur la feuille BD). Vous pouvez dans une autre feuille établir un formulaire qui affiche les données du produit lorsque vous indiquer un code. Je rappelle que dans la liste de données le champ Photo doit contenir l'adresse (chemin) de la photo et non la photo elle-même.
Votre formulaire pourrait alors ressembler à ceci :

 
A
B
C
1
Code AFG
2
Photo
3
Intitulé =RECHERCHEV(B1;BD!A:D;2;VRAI) =RECHERCHEV(B1;BD!A:D;3;VRAI)
4
5
Nb en stock =RECHERCHEV(B1;BD!A:D;4;VRAI)
6

Ensuite ajouter un bouton sur cette feuille depuis la barre d'outils Formulaires, affectez-lui la procédure suivante et renommez le MAJ

Sub InsertPhoto()
Dim strChem As String, strPhoto As String
'si une image a déjà été ajoutée alors on la supprime
If ActiveSheet.OLEObjects.Count > 0 Then
ActiveSheet.OLEObjects(1).Delete
End If
' la cellule "C3" doit contenir le nom du fichier image
strPhoto = Range("C3")
Range("C3").Select 'permet à l'insertion de l'image de se mettre dans la cellule (coin supérieur gauche)
'insère l'image avec liaison
ActiveSheet.OLEObjects.Add Filename:=strPhoto, Link:=True, DisplayAsIcon:=False
End Sub